SendGrid/AWS outage

Incident Report for BlueVolt Platform Status

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 00:27 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 00:26 PDT

Monitoring

We're monitoring an issue with our third party vendor, SendGrid, that's affecting the sending of email and notifications. Their vendor, AWS, has implemented a mitigation and is in the process of recovery. More info here: https://status.sendgrid.com/
Posted Oct 20, 2025 - 10:42 PDT
This incident affected: Notifications & scheduled reports.