Platform slowness

Incident Report for BlueVolt Platform Status

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 07:21 PDT

Monitoring

A fix has been implemented and we're monitoring the impact.
Posted Oct 08, 2025 - 16:16 PDT

Identified

We've identified an issue that's causing intermittent latency across the platform. We're working on a fix to issue.
Posted Oct 08, 2025 - 12:11 PDT
This incident affected: Admin and Learner UI.