Admin portal is not loading for some universities

Incident Report for BlueVolt Platform Status

Resolved

This incident has been closed.
Posted Jul 14, 2025 - 12:01 PDT

Update

The issue has been resolved and the portal is working as expected.
Posted Jul 14, 2025 - 11:57 PDT

Identified

The issue has been identified and we're working to apply a fix. ETA is 1p PST.
Posted Jul 14, 2025 - 08:22 PDT

Investigating

We're currently investigating the issue and will provide updates accordingly.
Posted Jul 14, 2025 - 06:40 PDT
This incident affected: Admin.