Dashboards not loading [Microsoft Fabric outage]

Incident Report for BlueVolt Platform Status

Resolved

This incident is now resovled
Posted Oct 21, 2025 - 12:44 PDT

Investigating

We're currently investigating an issue with our third party vendor, Microsoft Fabric, that's preventing Admin dashboards from loading. More info here: https://support.fabric.microsoft.com/support/
Posted Oct 21, 2025 - 09:11 PDT
This incident affected: Dashboard.