Email management page is timing out for some users

Incident Report for BlueVolt Platform Status

Resolved

This incident has been resolved
Posted Dec 13, 2023 - 07:41 PST

Identified

We've identified a fix and working to implement it. ETA is mid-December.
Posted Sep 19, 2023 - 06:54 PDT

Investigating

We are currently investigating the issue.
Posted Sep 13, 2023 - 14:45 PDT