Slower platform response times

Incident Report for BlueVolt Platform Status

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 09:54 PST

Monitoring

We've implemented a fix and we're monitoring response times which are improving.
Posted Nov 21, 2025 - 08:26 PST

Investigating

We're currently investigating an issue that's causing slower than normal response times across the platform for some users.
Posted Nov 21, 2025 - 08:10 PST
This incident affected: Admin, Learner UI, API, Automation Suite, and Dashboard.